summaryrefslogtreecommitdiff
path: root/lib/radsecproxy/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/radsecproxy/Makefile.am')
-rw-r--r--lib/radsecproxy/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/lib/radsecproxy/Makefile.am b/lib/radsecproxy/Makefile.am
new file mode 100644
index 0000000..16b66ae
--- /dev/null
+++ b/lib/radsecproxy/Makefile.am
@@ -0,0 +1,18 @@
+AUTOMAKE_OPTIONS = foreign
+ACLOCAL_AMFLAGS = -I m4
+
+INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)
+AM_CFLAGS = -Wall -g
+
+noinst_LTLIBRARIES = libradsec-radsecproxy.la
+
+libradsec_radsecproxy_la_SOURCES = \
+ debug.c \
+ hash.c \
+ list.c \
+ util.c
+
+if RS_ENABLE_TLS
+libradsec_radsecproxy_la_SOURCES += \
+ tlscommon.c
+endif