summaryrefslogtreecommitdiff
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@gnome.org>2013-01-02 16:06:19 +0100
committerStef Walter <stefw@gnome.org>2013-02-05 14:54:53 +0100
commit18bb2582c32f4373f7ed85894fb490f2733cb03b (patch)
tree3ecdcbc5451beb67e095ebaf0f233cdfd680ad94 /common/Makefile.am
parent3b482acc47ba971406db526ebddf589ad1a8f16e (diff)
Implement stapled certificate extensions internally
* Use stapled certificate extensions to represent loaded trust policy * Build NSS trust objects from stapled certificate extensions * Add further attribute debugging for NSS trust objects * Use a custom certificate extension for the OpenSSL reject purpose data * Use SubjectKeyIdentifier for OpenSSL keyid data * Use ExtendedKeyUsage for OpenSSL trust purpose data * Implement simple way to handle binary DER OIDs, using the DER TLV length. DER OIDs are used in the CKA_OBJECT_ID value, and elsewhere. * Split out the building of NSS trust objects from the main parser
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index d527e95..bed4630 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -41,6 +41,7 @@ noinst_LTLIBRARIES += \
libp11_data_la_SOURCES = \
base64.c base64.h \
checksum.c checksum.h \
+ oid.c oid.h \
openssl.asn openssl.asn.h \
pem.c pem.h \
pkix.asn pkix.asn.h \