summaryrefslogtreecommitdiff
path: root/common/tests/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stef@thewalter.net>2013-07-17 11:57:02 +0200
committerStef Walter <stef@thewalter.net>2013-07-18 08:45:57 +0200
commit936e4c229a4ed205e9981fc4f31acea063701b69 (patch)
treef6f9c7fcbee8a097e7b1abfad9c4bdd8552708cc /common/tests/Makefile.am
parent81a6e16539e5e4a27c55194ae095cc4a75d08ade (diff)
Don't load configs from user directory when setuid
When running as setuid() or setgid() don't access the user's home directory, or use $HOME environment variables. https://bugzilla.redhat.com/show_bug.cgi?id=985014
Diffstat (limited to 'common/tests/Makefile.am')
-rw-r--r--common/tests/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/common/tests/Makefile.am b/common/tests/Makefile.am
index 637399b..b1a42bd 100644
--- a/common/tests/Makefile.am
+++ b/common/tests/Makefile.am
@@ -7,7 +7,9 @@ AM_CPPFLAGS = \
-I$(top_srcdir) \
-I$(srcdir)/.. \
-I$(COMMON) \
- $(TEST_CFLAGS)
+ -DBUILDDIR=\"$(abs_builddir)\" \
+ $(TEST_CFLAGS) \
+ $(CUTEST_CFLAGS)
LDADD = \
$(NULL)
@@ -26,6 +28,7 @@ CHECK_PROGS = \
$(NULL)
noinst_PROGRAMS = \
+ frob-getauxval \
$(CHECK_PROGS)
TESTS = $(CHECK_PROGS)