summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaiki Ueno <dueno@redhat.com>2018-01-31 10:27:43 +0100
committerDaiki Ueno <ueno@gnu.org>2018-01-31 15:51:28 +0100
commit3a88f2ed573a5bb04d2397c626f6bcf3b1a814da (patch)
tree70afbb882307a7cf447bff109e5b48a31cfe9cec /configure.ac
parent57697eda68a3343c2e54e5f8f3f4ce65a99383f5 (diff)
build: Split out generated code from p11-kit/virtual.c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6f49ed4..dde92b4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -217,6 +217,19 @@ fi
AM_CONDITIONAL(WITH_FFI, test "$with_libffi" = "yes")
+AC_ARG_WITH([closures],
+ [AS_HELP_STRING([--with-closures[=NUM]],
+ [the number of precompiled closures, used when libffi is unavailable])],
+ [closures=$withval],
+ [closures=64])
+
+if test "$closures" -lt 1; then
+ AC_MSG_ERROR([at least one closure must be compiled in])
+fi
+
+AC_DEFINE_UNQUOTED(P11_VIRTUAL_MAX_FIXED, [$closures], [the number of closures])
+AC_SUBST(closures)
+
# --------------------------------------------------------------------
# Hash implementation