summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStef Walter <stefw@gnome.org>2013-03-03 09:44:42 +0100
committerStef Walter <stefw@gnome.org>2013-03-03 10:07:08 +0100
commit7823c9ddcb18b5155b3cc0e9d9f57ad0333d5eba (patch)
tree731a2337e44fd765f58ad0886a25be113da36c06 /configure.ac
parent02d7da2ba2247d017f248dd48e4365bd0a219bff (diff)
Add compat implementation of basename()
For Win32 and older unixes
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e843dfa..ef6f06f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -72,9 +72,10 @@ if test "$os_unix" = "yes"; then
[AC_MSG_ERROR([could not find dlopen])])
AC_SEARCH_LIBS([nanosleep], [rt], [],
[AC_MSG_ERROR([could not find nanosleep])])
+
+ # These are thngs we can work around
AC_CHECK_MEMBERS([struct dirent.d_type],,,[#include <dirent.h>])
- AC_CHECK_FUNCS([getprogname getexecname memdup])
- AC_CHECK_FUNCS([getprogname getexecname strnstr memdup])
+ AC_CHECK_FUNCS([getprogname getexecname basename mkstemp mkdtemp])
# Check if these are declared and/or available to link against
AC_CHECK_DECLS([program_invocation_short_name])