summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStef Walter <stefw@collabora.co.uk>2011-01-22 14:45:57 -0600
committerStef Walter <stefw@collabora.co.uk>2011-01-22 14:45:57 -0600
commitc2a5aaf7baf4bcc006674a1938205f93028b8ab0 (patch)
treec6db4d82e1b673c33fdf8ee37c9dd434a40d72d3 /configure.ac
parenta50ba779ff3e0a5d4f35fb2b6ab525a423575cc4 (diff)
Rough idea of possible library functions.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d15ec71..c2ee23d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,12 +18,15 @@ AC_PROG_CPP
AM_PROG_CC_C_O
dnl Checks for libraries.
-
AC_CHECK_LIB(pthread, pthread_mutex_lock,,
[AC_MSG_ERROR([could not find pthread_mutex_lock])])
AC_CHECK_LIB(dl, dlopen,,
[AC_MSG_ERROR([could not find dlopen])])
+
+dnl Checks for typedefs, structures, and compiler characteristics.
+AC_CHECK_MEMBERS([struct dirent.d_type],,,[#include <dirent.h>])
+
# --------------------------------------------------------------------
# PAM Module Directory