summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStef Walter <stefw@gnome.org>2013-03-18 22:27:48 +0100
committerStef Walter <stefw@gnome.org>2013-03-18 22:38:29 +0100
commitcaaeaffb86c572f996bec31f67443da2219def84 (patch)
treeddd589a2ca877fc26bfd62c96ac1179edde431cc /configure.ac
parent6c47831b3bfc66e1e995fb27e80c23085bb41e08 (diff)
Release version 0.17.1
* Fix distcheck bugs surrounding the strndup() workaround
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 2 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 02e7793..114f6e7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,7 +1,7 @@
AC_PREREQ(2.61)
AC_INIT([p11-kit],
- [0.17.0],
+ [0.17.1],
[https://bugs.freedesktop.org/enter_bug.cgi?product=p11-glue],
[p11-kit],
[http://p11-glue.freedesktop.org/p11-kit.html])
@@ -78,15 +78,10 @@ if test "$os_unix" = "yes"; then
# These are thngs we can work around
AC_CHECK_MEMBERS([struct dirent.d_type],,,[#include <dirent.h>])
AC_CHECK_FUNCS([getprogname getexecname basename mkstemp mkdtemp])
- AC_CHECK_FUNCS([strnstr memdup])
+ AC_CHECK_FUNCS([strnstr memdup strndup])
AC_CHECK_FUNCS([asprintf vasprintf vsnprintf])
AC_CHECK_FUNCS([timegm])
- # WORKAROUND: So in lots of released builds of firefox a completely broken strndup()
- # is present. It does not NULL terminate its string output. It is unconditionally
- # defined, and overrides the libc strndup() function on platforms where it
- # exists. For this reason we (for now) unconditionally define strndup().
-
# Required functions
AC_CHECK_FUNCS([gmtime_r],
[AC_DEFINE([HAVE_GMTIME_R], 1, [Whether gmtime_r() is available])],