summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStef Walter <stefw@gnome.org>2013-03-03 09:57:24 +0100
committerStef Walter <stefw@gnome.org>2013-03-03 10:07:14 +0100
commitd9076a99c59bb0132b25277a2340f428c9b6c98e (patch)
tree8b0339f9e46b3f9b3eb2df8e5691030cde1eb6d5 /configure.ac
parent2737be8914270275d07ccf4526a4ba8b781c195e (diff)
Add compat gmtime_r() and timegm() functions
Not available on Win32 or ancient unixes
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ac049c9..1c618e9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -78,6 +78,12 @@ if test "$os_unix" = "yes"; then
AC_CHECK_FUNCS([getprogname getexecname basename mkstemp mkdtemp])
AC_CHECK_FUNCS([strnstr memdup strndup])
AC_CHECK_FUNCS([asprintf vasprintf vsnprintf])
+ AC_CHECK_FUNCS([timegm])
+
+ # Required functions
+ AC_CHECK_FUNCS([gmtime_r],
+ [AC_DEFINE([HAVE_GMTIME_R], 1, [Whether gmtime_r() is available])],
+ [AC_MSG_ERROR([could not find required gmtime_r() function])])
# Check if these are declared and/or available to link against
AC_CHECK_DECLS([program_invocation_short_name])