summaryrefslogtreecommitdiff
path: root/p11-kit/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2016-08-24 11:40:21 +0200
committerDaiki Ueno <ueno@gnu.org>2017-02-17 10:25:55 +0100
commit4bac7e0e95712a4c7bfd03471c973f491ad81df4 (patch)
tree045caff5782f810c979c189d534404692c5e1dfa /p11-kit/Makefile.am
parentf2742c72bc29444bcfe63425819506fa42073d64 (diff)
p11-kit: Add 'p11-kit server' command
This adds a new tool to the p11-kit command called 'server', which allows us to access a PKCS#11 module over a Unix domain socket. Internally, it is implemented as a wrapper around 'p11-kit remote'. Upon connection it executes 'p11-kit remote' in a forked process.
Diffstat (limited to 'p11-kit/Makefile.am')
-rw-r--r--p11-kit/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/p11-kit/Makefile.am b/p11-kit/Makefile.am
index d51c052..d53f51c 100644
--- a/p11-kit/Makefile.am
+++ b/p11-kit/Makefile.am
@@ -149,6 +149,20 @@ p11_kit_remote_LDADD = \
libp11-kit.la \
$(NULL)
+if !OS_WIN32
+private_PROGRAMS += p11-kit-server
+
+p11_kit_server_SOURCES = \
+ p11-kit/server.c \
+ $(NULL)
+
+p11_kit_server_LDADD = \
+ libp11-tool.la \
+ libp11-common.la \
+ libp11-kit.la \
+ $(NULL)
+endif
+
# Tests ----------------------------------------------------------------
p11_kit_LIBS = \