summaryrefslogtreecommitdiff
path: root/p11-kit/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@collabora.co.uk>2011-05-27 14:42:35 +0200
committerStef Walter <stefw@collabora.co.uk>2011-05-27 14:45:44 +0200
commitbdd6188e299405e16179906bc79f9fef2605176a (patch)
tree6d1654e4ee6c4411f1a8075c89353e5ee25c46d2 /p11-kit/Makefile.am
parent92f821b6883e700a97a18d244104dea1031f2dce (diff)
Change around installation of headers, pkg-config, and file names
* Install headers to ${prefix}/include/p11-kit-1/p11-kit/ * This solves problems with other projects that have their own pkcs11.h files. * Change the pkg-config file name to p11-kit-1.pc * Change the source file names.
Diffstat (limited to 'p11-kit/Makefile.am')
-rw-r--r--p11-kit/Makefile.am18
1 files changed, 9 insertions, 9 deletions
diff --git a/p11-kit/Makefile.am b/p11-kit/Makefile.am
index 0b7e163..1f2de49 100644
--- a/p11-kit/Makefile.am
+++ b/p11-kit/Makefile.am
@@ -2,11 +2,11 @@
INCLUDES = \
-DP11_KIT_API_SUBJECT_TO_CHANGE
-incdir = $(includedir)/p11-kit
+incdir = $(includedir)/p11-kit-1/p11-kit
inc_HEADERS = \
p11-kit.h \
- p11-kit-uri.h \
+ uri.h \
pkcs11.h
MODULE_SRCS = \
@@ -14,11 +14,11 @@ MODULE_SRCS = \
debug.c debug.h \
hash.c hash.h \
util.c util.h \
- p11-kit-lib.c \
- p11-kit-proxy.c \
- p11-kit-private.h \
- p11-kit-messages.c \
- p11-kit-uri.c \
+ modules.c \
+ proxy.c \
+ private.h \
+ messages.c \
+ uri.c \
$(inc_HEADERS)
lib_LTLIBRARIES = \
@@ -38,7 +38,7 @@ libp11_kit_testable_la_LDFLAGS = \
libp11_kit_testable_la_SOURCES = $(MODULE_SRCS)
pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = p11-kit.pc
+pkgconfig_DATA = p11-kit-1.pc
EXTRA_DIST = \
- p11-kit.pc.in \ No newline at end of file
+ p11-kit-1.pc.in \ No newline at end of file