summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@gnome.org>2013-01-30 15:30:52 +0100
committerStef Walter <stefw@gnome.org>2013-02-05 15:00:24 +0100
commit722efb88cf12261d705e2a6dfb4aceab9ff7b76f (patch)
treea58e8a82441fe33cfbb1f408b2c662d73c1f6c48 /tools/Makefile.am
parent9a21e6ddf9eb7bb0f13f01cddba9dedd7a6e43b3 (diff)
Implement basic extract support
* The only formats supported are x509-file and x509-directory Allow tool to build without extract
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am20
1 files changed, 19 insertions, 1 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index fab1bd9..d07eda0 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -18,13 +18,31 @@ bin_PROGRAMS = \
p11_kit_SOURCES = \
list.c \
- save.c save.h \
tool.c tool.h \
$(NULL)
+p11_kit_CFLAGS = \
+ $(LIBTASN1_CFLAGS) \
+ $(NULL)
+
p11_kit_LDADD = \
$(top_builddir)/p11-kit/libp11-kit.la \
$(top_builddir)/common/libp11-library.la \
$(top_builddir)/common/libp11-compat.la \
$(LTLIBINTL) \
$(NULL)
+
+if WITH_ASN1
+
+p11_kit_LDADD += \
+ $(top_builddir)/common/libp11-data.la \
+ $(LIBTASN1_LIBS)
+
+p11_kit_SOURCES += \
+ extract.c extract.h \
+ extract-info.c \
+ extract-x509.c \
+ save.c save.h \
+ $(NULL)
+
+endif # WITH_ASN1