summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@gnome.org>2013-01-08 12:27:48 +0100
committerStef Walter <stefw@gnome.org>2013-01-09 13:49:44 +0100
commit8fb222266c5bf9181cd934c27528507d45476dad (patch)
tree23ac84c98f7c84e2a699eb5f09580b43a94f13d9 /tools/Makefile.am
parent3d503948450d69293a3fdfec096e398fedf714f2 (diff)
Build common code into noinst libraries
* This is cleaner than building the same source files all over the place over and over. * Works better with code coverage.
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index bfa1953..44b8432 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -1,3 +1,6 @@
+NULL =
+
+COMMON = $(top_srcdir)/common
INCLUDES = \
-I$(top_srcdir) \
@@ -9,10 +12,11 @@ bin_PROGRAMS = \
p11-kit
p11_kit_SOURCES = \
- $(top_srcdir)/common/compat.c \
- $(top_srcdir)/common/compat.h \
- p11-kit.c
+ p11-kit.c \
+ $(NULL)
p11_kit_LDADD = \
$(top_builddir)/p11-kit/libp11-kit.la \
- $(LTLIBINTL)
+ $(top_builddir)/common/libp11-compat.la \
+ $(LTLIBINTL) \
+ $(NULL)