summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@collabora.co.uk>2011-10-17 14:51:31 +0200
committerStef Walter <stefw@collabora.co.uk>2011-10-17 15:32:41 +0200
commitdb92b76e3acb11e330309ebce071ec2e61400a71 (patch)
treecb11139880974ef8db53dd83a70de8f32d94cc09 /tools/Makefile.am
parentb1d9fd5f88ade222fbd2206c7e11c5514c8b5634 (diff)
Initial port to win32
* Tests do not all yet pass, at least not on wine * Added abstraction of some non-portable functions in compat.h/c * Build with an argument like this for win32 support: ./autogen.sh --host=i586-mingw32msvc * This win32 port needs more work from interested parties
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 13920d7..e38d1a4 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -7,6 +7,10 @@ INCLUDES = \
bin_PROGRAMS = \
p11-kit
+p11_kit_SOURCES = \
+ compat.c compat.h \
+ p11-kit.c
+
p11_kit_LDADD = \
$(top_builddir)/p11-kit/libp11-kit.la \
$(LTLIBINTL)