summaryrefslogtreecommitdiff
path: root/tools/tests/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@gnome.org>2013-04-05 23:52:39 +0200
committerStef Walter <stefw@gnome.org>2013-05-21 11:31:09 +0200
commitdcabaf1d56d410ba7ddb3dfbab9011bbbea5e6bc (patch)
treec49effa4a0696dc00fb591d95dc59e8579a8d030 /tools/tests/Makefile.am
parent7fd6d89d92b6f1b543bf2aa4b2e578201dad7147 (diff)
Our own unit testing framework
* Support the TAP protocol * Much cleaner without having to carry around state * First class support for setup/teardown * Port the common tests * Wait on porting other tests until we've merged outstanding code
Diffstat (limited to 'tools/tests/Makefile.am')
-rw-r--r--tools/tests/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/tools/tests/Makefile.am b/tools/tests/Makefile.am
index f6609ec..667bf12 100644
--- a/tools/tests/Makefile.am
+++ b/tools/tests/Makefile.am
@@ -17,13 +17,13 @@ INCLUDES = \
-I$(COMMON) \
-DP11_KIT_FUTURE_UNSTABLE_API \
$(LIBTASN1_CFLAGS) \
- $(CUTEST_CFLAGS) \
+ $(TEST_CFLAGS) \
$(NULL)
LDADD = \
$(top_builddir)/p11-kit/libp11-kit.la \
$(top_builddir)/common/libp11-data.la \
- $(top_builddir)/common/libp11-mock.la \
+ $(top_builddir)/common/libp11-test.la \
$(top_builddir)/common/libp11-common.la \
$(builddir)/libtestcommon.la \
$(LIBTASN1_LIBS) \
@@ -35,7 +35,7 @@ noinst_LTLIBRARIES = \
libtestcommon.la
libtestcommon_la_SOURCES = \
- test.c test.h
+ test-tools.c test-tools.h
CHECK_PROGS = \
test-save \