summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 44b8432..43adf56 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -6,17 +6,22 @@ INCLUDES = \
-I$(top_srcdir) \
-I$(top_srcdir)/common \
-I$(top_srcdir)/p11-kit \
- -DSRCDIR=\"$(srcdir)\"
+ -DSRCDIR=\"$(srcdir)\" \
+ -DPKGDATADIR=\"$(pkgdatadir)\" \
+ -DP11_KIT_FUTURE_UNSTABLE_API \
+ $(NULL)
bin_PROGRAMS = \
p11-kit
p11_kit_SOURCES = \
- p11-kit.c \
+ list.c \
+ tool.c tool.h \
$(NULL)
p11_kit_LDADD = \
$(top_builddir)/p11-kit/libp11-kit.la \
+ $(top_builddir)/common/libp11-library.la \
$(top_builddir)/common/libp11-compat.la \
$(LTLIBINTL) \
$(NULL)