summaryrefslogtreecommitdiff
path: root/tools/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/tests/Makefile.am')
-rw-r--r--tools/tests/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/tools/tests/Makefile.am b/tools/tests/Makefile.am
index bf1d32d..e50836d 100644
--- a/tools/tests/Makefile.am
+++ b/tools/tests/Makefile.am
@@ -37,10 +37,12 @@ libtestcommon_la_SOURCES = \
test.c test.h
CHECK_PROGS = \
+ test-utf8 \
test-save \
test-extract \
test-x509 \
test-pem \
+ test-openssl \
$(NULL)
noinst_PROGRAMS = \
@@ -72,4 +74,17 @@ test_pem_SOURCES = \
$(TOOLS)/save.c \
$(NULL)
+test_openssl_SOURCES = \
+ test-openssl.c \
+ $(TOOLS)/extract-info.c \
+ $(TOOLS)/extract-openssl.c \
+ $(TOOLS)/save.c \
+ $(TOOLS)/utf8.c \
+ $(NULL)
+
+test_utf8_SOURCES = \
+ test-utf8.c \
+ $(TOOLS)/utf8.c \
+ $(NULL)
+
endif # WITH_ASN1