summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLinus Nordberg <linus@nordu.net>2011-09-27 19:50:13 +0200
committerLinus Nordberg <linus@nordu.net>2011-09-27 19:50:13 +0200
commitae485fd8711bff7147853515fcf9a8e04c217c5d (patch)
tree71177b10a97d0768b9f28abc61a85f8b1d0e460a /Makefile.am
parentf2d92c0dc60d1fbca3ad1822053ae2d30a88e8d7 (diff)
Pass necessary compiler and linker flags.
All the source files compiled into the library needs all flags too.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 70f9284..f83295c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -34,9 +34,11 @@ catgconf_SOURCES = \
gconfig.c \
catgconf.c
-radsecproxy_CFLAGS = \
+librsp_a_CFLAGS = \
-g -Wall -Werror -fno-strict-aliasing @SSL_CFLAGS@ @TARGET_CFLAGS@
-radsecproxy_LDFLAGS = @SSL_LDFLAGS@ @TARGET_LDFLAGS@
+librsp_a_LDFLAGS = @SSL_LDFLAGS@ @TARGET_LDFLAGS@
+radsecproxy_CFLAGS = $(librsp_a_CFLAGS)
+radsecproxy_LDFLAGS = $(librsp_a_LDFLAGS)
radsecproxy_LDADD = librsp.a @SSL_LIBS@
catgconf_CFLAGS = -g -Wall -fno-strict-aliasing @TARGET_CFLAGS@