summaryrefslogtreecommitdiff
path: root/packaging/gentoo/net-dialup/radsecproxy/radsecproxy-1.0_alpha1.ebuild
diff options
context:
space:
mode:
authorvenaas <venaas>2007-06-19 09:27:26 +0000
committervenaas <venaas@e88ac4ed-0b26-0410-9574-a7f39faa03bf>2007-06-19 09:27:26 +0000
commit8e5146e56b9b0023f4c4e82fa1af4a01a0c9265f (patch)
tree8c109dedbd4db7bbd892bc7666331a06c86c5eae /packaging/gentoo/net-dialup/radsecproxy/radsecproxy-1.0_alpha1.ebuild
parent7799f8b5b69dc62e1bc0d429a50d79e438c86cef (diff)
added package files, note that some were also added in previous commit
git-svn-id: https://svn.testnett.uninett.no/radsecproxy/trunk@143 e88ac4ed-0b26-0410-9574-a7f39faa03bf
Diffstat (limited to 'packaging/gentoo/net-dialup/radsecproxy/radsecproxy-1.0_alpha1.ebuild')
-rw-r--r--packaging/gentoo/net-dialup/radsecproxy/radsecproxy-1.0_alpha1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/packaging/gentoo/net-dialup/radsecproxy/radsecproxy-1.0_alpha1.ebuild b/packaging/gentoo/net-dialup/radsecproxy/radsecproxy-1.0_alpha1.ebuild
new file mode 100644
index 0000000..bbd07e3
--- /dev/null
+++ b/packaging/gentoo/net-dialup/radsecproxy/radsecproxy-1.0_alpha1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: radsecproxy-1.0_alpha1.ebuild 12 2007-06-14 19:53:35Z kolla $
+
+inherit eutils
+
+MY_P=${P%_alpha1}-alpha-p1
+S=${S%_alpha1}-alpha-p1
+
+DESCRIPTION="RADIUS/RADSEC Proxy"
+HOMEPAGE="http://software.uninett.no/radsecproxy"
+SRC_URI="http://software.uninett.no/${PN}/${MY_P}.tar.gz"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="x86 ~alpha ~amd64 ~arm ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390"
+
+IUSE=""
+
+DEPEND="dev-libs/openssl"
+RDEPEND="dev-libs/openssl"
+
+src_unpack() {
+ unpack ${A}
+ # Use sbin instead of bin
+ sed 's:^bin_PROGRAMS:sbin_PROGRAMS:' -i "${S}"/Makefile.am
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+}
+
+pkg_postinst () {
+ echo
+ elog "Example config exists as /etc/radsecproxy.conf-example"
+ elog "Copy this to /etc/radsecproxy.conf and edit to suit your needs"
+ echo
+}