summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index de8652e..7c06725 100644
--- a/configure.ac
+++ b/configure.ac
@@ -50,7 +50,10 @@ dnl Check if we're on Solaris and set CFLAGS accordingly
AC_CANONICAL_SYSTEM
case "${target_os}" in
solaris*)
- TARGET_CFLAGS="-mt -DSYS_SOLARIS9 -D_POSIX_PTHREAD_SEMANTICS"
+ TARGET_CFLAGS="-DSYS_SOLARIS9 -D_POSIX_PTHREAD_SEMANTICS"
+ if test "$GCC" != yes ; then
+ TARGET_CFLAGS="$TARGET_CFLAGS -mt"
+ fi
TARGET_LDFLAGS="-lpthread -lsocket -lnsl"
;;
*)