summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLinus Nordberg <linus@nordberg.se>2013-08-26 12:04:07 +0200
committerLinus Nordberg <linus@nordberg.se>2013-08-26 12:08:44 +0200
commit3bd0555f888da46a9ad7596b393d6f21f6b0221c (patch)
tree03629bcfe26f2cf9cf50e6c3c31140af67989c5c /configure.ac
parent9174b0aca94fae0c483e2ae10608d660dc52f9c4 (diff)
Return free memory more aggressively.
Have free(3) call sbrk(2) when there's 4 MB to free (default on Linux seems to be 128). Patch by Fabian Mauchle.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e5df020..4c500e7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
dnl Copyright (c) 2006-2010, UNINETT AS
-dnl Copyright (c) 2010-2012, NORDUnet A/S
+dnl Copyright (c) 2010-2013, NORDUnet A/S
dnl See LICENSE for licensing information.
AC_INIT(radsecproxy, 1.7-dev, radsecproxy@uninett.no)
@@ -7,6 +7,8 @@ AC_CANONICAL_TARGET
AM_INIT_AUTOMAKE
AC_PROG_CC
AC_PROG_RANLIB
+AC_CHECK_FUNCS([mallopt])
+
udp=yes
AC_ARG_ENABLE(udp,
[ --enable-udp whether to enable UDP transport: yes/no; default yes ],