summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorlinus <linus>2010-03-31 11:50:43 +0000
committerlinus <linus@e88ac4ed-0b26-0410-9574-a7f39faa03bf>2010-03-31 11:50:43 +0000
commit730d77eec5daae3ed3c6509a1643f7c8ce27c445 (patch)
treef77ffba07130e2f469454f6a18905e9bcfef903e /configure.ac
parent5d80fb5e4ff9af652721110f057ddaa5bebb6650 (diff)
Pass `-pthread' to gcc on Solaris.
git-svn-id: https://svn.testnett.uninett.no/radsecproxy/trunk@537 e88ac4ed-0b26-0410-9574-a7f39faa03bf
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c8dd005..7585a60 100644
--- a/configure.ac
+++ b/configure.ac
@@ -54,6 +54,8 @@ case "${target_os}" in
TARGET_CFLAGS="-DSYS_SOLARIS9 -D_POSIX_PTHREAD_SEMANTICS"
if test "$GCC" != yes ; then
TARGET_CFLAGS="$TARGET_CFLAGS -mt"
+ else
+ TARGET_CFLAGS="$TARGET_CFLAGS -pthread"
fi
TARGET_LDFLAGS="-lpthread -lsocket -lnsl"
;;