summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorLeif Johansson <leifj@sunet.se>2011-01-26 14:42:17 +0100
committerLeif Johansson <leifj@sunet.se>2011-01-26 14:42:17 +0100
commit4a19966c3bb9f7dce1cca158163d583a33458723 (patch)
treebbe55f7b708c52011052c9bf9afdddc6be4a9755 /Makefile.PL
import
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL23
1 files changed, 23 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100755
index 0000000..b90d45d
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,23 @@
+use ExtUtils::MakeMaker;
+# See lib/ExtUtils/MakeMaker.pm for details of how to influence
+# the contents of the Makefile that is written.
+WriteMakefile(
+ 'NAME' => 'LDAPShell',
+ 'VERSION_FROM' => 'LDAPShell.pm', # finds $VERSION
+ 'PREREQ_PM' => {
+ Net::LDAP=>0,
+ Net::LDAP::LDIF=>0,
+ Term::ReadLine::Gnu=>0,
+ Term::ReadLine=>0,
+ Term::ANSIColor=>0,
+ Getopt::Long=>0,
+ URI=>0,
+ Text::FormatTable=>0,
+ Unicode::String=>0,
+ ResourcePool=>0,
+ ResourcePool::Factory::Net::LDAP=>0
+ },
+ ($] >= 5.005 ? ## Add these new keywords supported since 5.005
+ (ABSTRACT_FROM => 'LDAPShell.pm', # retrieve abstract from module
+ AUTHOR => 'A. U. Thor <a.u.thor@a.galaxy.far.far.away>') : ()),
+);