summaryrefslogtreecommitdiff
path: root/radius/Makefile.am
diff options
context:
space:
mode:
authorLinus Nordberg <linus@nordberg.se>2014-02-05 11:10:02 +0100
committerLinus Nordberg <linus@nordberg.se>2014-02-05 11:10:02 +0100
commit3d954bfd2f658ac05a0f20a1241738ed3e3fdd28 (patch)
treed95b364fbab298c9b94c9c729afc98904c7c5bb0 /radius/Makefile.am
parent67bdfa83f1879312fef0fbac769f6fb45df12d1a (diff)
Move lib to the root.
Diffstat (limited to 'radius/Makefile.am')
-rw-r--r--radius/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/radius/Makefile.am b/radius/Makefile.am
new file mode 100644
index 0000000..462a1e0
--- /dev/null
+++ b/radius/Makefile.am
@@ -0,0 +1,42 @@
+AUTOMAKE_OPTIONS = foreign
+ACLOCAL_AMFLAGS = -I m4
+
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)
+AM_CFLAGS = -Wall -g
+
+noinst_LTLIBRARIES = libradsec-radius.la
+
+libradsec_radius_la_SOURCES = \
+ attrs.c \
+ crypto.c \
+ custom.c \
+ dict.c \
+ id.c \
+ parse.c \
+ print.c \
+ radpkt.c \
+ static.c \
+ valuepair.c
+
+libradsec_radius_la_SOURCES += client.h
+
+libradsec_radius_la_CFLAGS = $(AM_CFLAGS) -DHAVE_CONFIG_H
+
+DICTIONARIES = \
+ share/dictionary.txt \
+ share/dictionary.juniper \
+ share/dictionary.microsoft \
+ share/dictionary.ukerna \
+ share/dictionary.abfab.ietf
+
+EXTRA_DIST = dictionaries.c $(DICTIONARIES) common.pl convert.pl
+
+$(top_srcdir)/include/radsec/radius.h dictionaries.c: ${DICTIONARIES} convert.pl common.pl
+ $(srcdir)/convert.pl ${DICTIONARIES}
+
+static.$(OBJEXT): static.c dictionaries.c
+
+clean-local:
+ rm -f dictionaries.c
+
+$(libradsec_radius_la_SOURCES): $(top_srcdir)/include/radsec/radius.h