summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index ca7de1f..fb1f0ae 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -14,15 +14,19 @@ libradsec_la_SOURCES = \
err.c \
packet.c \
radsec.c \
- request.c \
- tls.c
+ request.c
libradsec_la_SOURCES += \
rsp_debug.c \
rsp_hash.c \
rsp_list.c \
- rsp_tlscommon.c \
rsp_util.c
+if RS_ENABLE_TLS
+libradsec_la_SOURCES += \
+ tls.c \
+ rsp_tlscommon.c
+endif
+
libradsec_la_LDFLAGS = -version-info 0:0:0
libradsec_la_CFLAGS = $(CFLAGS) -DDEBUG -DDEBUG_LEVENT